Propel Apps - Major Amazon Web Services outage impacting multiple services – Incident details

All systems operational

Major Amazon Web Services outage impacting multiple services

Resolved
Major outage
Started 3 months agoLasted 1 day

Affected

PropelPay

Degraded performance from 8:57 AM to 10:00 AM, Operational from 10:00 AM to 9:09 AM

Propeller

Degraded performance from 8:57 AM to 10:00 AM, Operational from 10:00 AM to 9:09 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Update
    Update

    Amazon has reported AWS is showing significant signs of recovery. The impact to Propeller & PropelPay has been minor and are now showing significant improvement.

  • Monitoring
    Monitoring

    We have been made aware that supporting services to our Propeller app have been impacted by a major outage to Amazon Web Services in the US. We are closely monitoring the situation and will issue an update as we know more.