Propel Apps - Major Cloudflare outage impacting multiple services – Incident details

All systems operational

Major Cloudflare outage impacting multiple services

Resolved
Partial outage 30 %
Started about 2 months agoLasted about 5 hours

Affected

PropelPay

Partial outage from 11:30 AM to 12:39 PM, Degraded performance from 12:39 PM to 2:52 PM, Operational from 2:52 PM to 4:11 PM

Propeller

Partial outage from 11:30 AM to 12:39 PM, Degraded performance from 12:39 PM to 2:52 PM, Operational from 2:52 PM to 4:11 PM

Propel Company Websites

Partial outage from 11:30 AM to 12:39 PM, Degraded performance from 12:39 PM to 2:52 PM, Operational from 2:52 PM to 4:11 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    Cloudflare have now implemented a fix and are continuing to monitor the incident.

  • Identified
    Identified

    Cloudflare have reported that services are starting to recover. We are continuing to monitor the situation and will provide an update once we have confirmation that supporting services are back online.

  • Investigating
    Investigating

    We have been made aware that supporting services to our PropelPay and Propeller app have been impacted by a major outage to Cloudflare. We are closely monitoring the situation and will issue an update as we know more.